Download WordPress Themes, Happy Birthday Wishes
Accueil » Algorithme » Exercices corrigés d’algorithme

Exercices corrigés d’algorithme

Télécharger gratuitement une série d’exercices sur d’algorithme, Document au format PDF de 7 pages.

Catégorie: Algorithme, type de fichier: PDF, Nombre de page: 7, auteur: , license: Creative commons, taille de fichier: 315.94 Kb, niveau: Débutant, date: 2017-11-05, téléchargement: 1632.

Exercice 1

Ecrire un algorithme qui demande à l’utilisateur un nombre compris entre 1 et 3 jusqu’à ce que la réponse convienne.

Exercice 2

Ecrire un algorithme qui demande un nombre de départ, et qui ensuite affiche les dix nombres suivants. Par exemple, si l’utilisateur entre le nombre 17, le programme affichera les nombres de 18 à 27.

Exercice 3

Réécrire l’algorithme précédent, en utilisant cette fois l’instruction Pour .

Exercice 4

Ecrire un algorithme qui demande un nombre de départ, et qui calcule sa factorielle.

NB : la factorielle de 8, notée 8 !, vaut 1 x 2 x 3 x 4 x 5 x 6 x 7 x 8

Exercice 5

Réécrire l’algorithme précédent, mais cette fois-ci on ne connaît pas d’avance combien l’utilisateur souhaite saisir de nombres. La saisie des nombres s’arrête lorsque l’utilisateur entre un zéro.

 

Trouvez le reste des exercices d’Algorithme et les solutions dans le fichier pdf.

 

Ce cours intitulé Exercices corrigés d’algorithme est à télécharger gratuitement, plusieurs autre documents sous la catégorie Algorithme sont disponibles dans ce site, que ce soit vous êtes débutant ou professionel ce cours de Algorithme va vous aider à améliorer votre compétence et votre savoire faire dans le Algorithme.

Profitez de ce manuel de formation en PDF pour comprendre mieux le Algorithme et enrichir votre connaissance.

Commencez à télécharger ce cours adapté pour vous et à apprendre Algorithme.

Télécharger

Extrait du cours :

Ecrire "Saisie erronée. Recommencez”
FinSi
FinTantQue
Fin
énoncé – retour au cours

Exercice 5.2
Variable N en Entier
Debut
N ← 0
Ecrire « Entrez un nombre entre 10 et 20 »
TantQue N 20
Lire N
Si N 20 Alors
Ecrire « Plus petit ! »
FinSi
FinTantQue
Fin
énoncé – retour au cours

Exercice 5.3
On peut imaginer deux variantes, strictement équivalentes :
Variables N, i en Entier
Debut
Ecrire « Entrez un nombre :  »
Lire N
Stop ← N+10
Ecrire « Les 10 nombres suiv ants sont :  »
TantQue N < Stop
N ← N+1
Ecrire N
FinTantQue
Fin
Ou bien :
Variables N, i en Entier
Debut
Ecrire "Entrez un nombre : "
Lire N
i ← 0
Ecrire "Les 10 nombres suivants sont : "
TantQue i < 10
i ← i + 1
Ecrire N + i
FinTantQue
Fin
énoncé – retour au cours

Exercice 5.4

Laisser une réponse

Votre adresse email ne sera pas publiéeLes champs requis sont surlignés *

*

x

Check Also

formation pdf d’introduction à l’algorithme

Télécharger cours sur formation pdf d'introduction à l'algorithme, tutoriel PDF gratuit de Programmation de 35 pages.